import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[A-Za-z0-9 ]+(?=\\|)";
final String string = "Manchester United 8547|12345678910\n"
+ " |12345678910\n"
+ "Manchester |12345678910\n"
+ "124587933 |12345678910\n"
+ "8457 Manchester United|12345678910\n"
+ " Manchester United|12345678910";
final String subst = "\\1\\2\\3";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}