using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=:)\s*""(.+?)""";
string input = @"'""formula_pretty"":""MoS2"", ""formula_pretty2"":""MoS3""'";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}