const regex = new RegExp('(?<=:)\\s*"(.+?)"', '')
const str = `'"formula_pretty":"MoS2", "formula_pretty2":"MoS3"'`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}