re = /(?<=:)\s*"(.+?)"/
str = '\'"formula_pretty":"MoS2", "formula_pretty2":"MoS3"\''
# Print the match result
str.match(re) do |match|
puts match.to_s
end