$re = '/(?<=:)\s*"(.+?)"/';
$str = '\'"formula_pretty":"MoS2", "formula_pretty2":"MoS3"\'';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);