package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?P<major>|[0-9]+)\.(?P<minor>[0-9]+)\.(?P<patch>|[0-9]+)-(?:(?P<GA>GA$)|(?P<PRO>PRO$)|(?P<SNAPSHOT>SNAPSHOT$)|(?P<RC>RC$))$`)
var str = `1.2.6-RC
1.2.4-GA
1.2.6-PRO
1.2.6-SNAPSHOT
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}