const regex = /^(?P<major>|[0-9]+)\.(?P<minor>[0-9]+)\.(?P<patch>|[0-9]+)-(?:(?P<GA>GA$)|(?P<PRO>PRO$)|(?P<SNAPSHOT>SNAPSHOT$)|(?P<RC>RC$))$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?P<major>|[0-9]+)\\.(?P<minor>[0-9]+)\\.(?P<patch>|[0-9]+)-(?:(?P<GA>GA$)|(?P<PRO>PRO$)|(?P<SNAPSHOT>SNAPSHOT$)|(?P<RC>RC$))$', 'gm')
const str = `1.2.6-RC
1.2.4-GA
1.2.6-PRO
1.2.6-SNAPSHOT
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}