import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?P<major>|[0-9]+)\\.(?P<minor>[0-9]+)\\.(?P<patch>|[0-9]+)-(?:(?P<GA>GA$)|(?P<PRO>PRO$)|(?P<SNAPSHOT>SNAPSHOT$)|(?P<RC>RC$))$";
final String string = "1.2.6-RC\n"
+ "1.2.4-GA\n"
+ "1.2.6-PRO\n"
+ "1.2.6-SNAPSHOT\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}