using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"'(\d{4})(\d{2})(\d{2}) (\d{2}:\d{2}:\d{2})'";
string substitution = @"'$1-$2-$3 $4'";
string input = @"INSERT INTO table (field, field, field, field, field, field, field, field, field, field, field, field, field, field, field, field, field, field, field, field, field, field, field)
VALUES (1, '3110000000', 2, '21/01/2011 12:06', '1016', 1, 2, 'asdddasdsd', 'addasddadsd', 'adadadaddaddssaddaadddddddsadsd', 'asdasdsdsdadsadsadadasd', '06003160485', 'adadasdddaddadddds', '50124', 'asdsdaddad', 'asddasdadsad', '03321807576', NULL, '20110121 12:07:00', 1, NULL, NULL, 22),";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}