const regex = /'(\d{4})(\d{2})(\d{2}) (\d{2}:\d{2}:\d{2})'/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\'(\\d{4})(\\d{2})(\\d{2}) (\\d{2}:\\d{2}:\\d{2})\'', 'gm')
const str = `INSERT INTO table (field, field, field, field, field, field, field, field, field, field, field, field, field, field, field, field, field, field, field, field, field, field, field)
VALUES (1, '3110000000', 2, '21/01/2011 12:06', '1016', 1, 2, 'asdddasdsd', 'addasddadsd', 'adadadaddaddssaddaadddddddsadsd', 'asdasdsdsdadsadsadadasd', '06003160485', 'adadasdddaddadddds', '50124', 'asdsdaddad', 'asddasdadsad', '03321807576', NULL, '20110121 12:07:00', 1, NULL, NULL, 22),`;
const subst = `'$1-$2-$3 $4'`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);