use strict;
my $str = 'INSERT INTO table (field, field, field, field, field, field, field, field, field, field, field, field, field, field, field, field, field, field, field, field, field, field, field)
VALUES (1, \'3110000000\', 2, \'21/01/2011 12:06\', \'1016\', 1, 2, \'asdddasdsd\', \'addasddadsd\', \'adadadaddaddssaddaadddddddsadsd\', \'asdasdsdsdadsadsadadasd\', \'06003160485\', \'adadasdddaddadddds\', \'50124\', \'asdsdaddad\', \'asddasdadsad\', \'03321807576\', NULL, \'20110121 12:07:00\', 1, NULL, NULL, 22),';
my $regex = qr/'(\d{4})(\d{2})(\d{2}) (\d{2}:\d{2}:\d{2})'/mp;
my $subst = '\'$1-$2-$3 $4\'';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";