// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)'(\d{4})(\d{2})(\d{2}) (\d{2}:\d{2}:\d{2})'").unwrap();
let string = "INSERT INTO table (field, field, field, field, field, field, field, field, field, field, field, field, field, field, field, field, field, field, field, field, field, field, field)
VALUES (1, '3110000000', 2, '21/01/2011 12:06', '1016', 1, 2, 'asdddasdsd', 'addasddadsd', 'adadadaddaddssaddaadddddddsadsd', 'asdasdsdsdadsadsadadasd', '06003160485', 'adadasdddaddadddds', '50124', 'asdsdaddad', 'asddasdadsad', '03321807576', NULL, '20110121 12:07:00', 1, NULL, NULL, 22),";
let substitution = "'$1-$2-$3 $4'";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}