using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\d{1,3}(?:\.\d{1,3}){2}\.(\d{1,3}))(?:(?:-|\s+to\s+)(\d{1,3}(?![\d\.]))|(?:-|\s*to\s+)(\d{1,3}(?:\.\d{1,3}){3})|\s+(25\d(?:\.\d{1,3}){3})|\s*\/(\d{1,3}))?";
string input = @"ip: ""47.1.2.3""
range: ""47.1.2.3-4""
ip range: ""47.1.2.3-47.1.2.4""
ip to range: ""47.1.2.3 to 4""
ip to ip range: ""47.1.2.3 to 47.1.2.4""
ip CIDR: ""47.1.2.4/32""
ip Mask: ""47.1.2.4 255.255.255.255""
what you want:""47.1.2.3 to 4, 47.1.2.7, 47.1.3.9-47.1.3.19""";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}