use strict;
my $str = 'ip: "47.1.2.3"
range: "47.1.2.3-4"
ip range: "47.1.2.3-47.1.2.4"
ip to range: "47.1.2.3 to 4"
ip to ip range: "47.1.2.3 to 47.1.2.4"
ip CIDR: "47.1.2.4/32"
ip Mask: "47.1.2.4 255.255.255.255"
what you want:"47.1.2.3 to 4, 47.1.2.7, 47.1.3.9-47.1.3.19"';
my $regex = qr/(\d{1,3}(?:\.\d{1,3}){2}\.(\d{1,3}))(?:(?:-|\s+to\s+)(\d{1,3}(?![\d\.]))|(?:-|\s*to\s+)(\d{1,3}(?:\.\d{1,3}){3})|\s+(25\d(?:\.\d{1,3}){3})|\s*\/(\d{1,3}))?/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}