import re
regex = re.compile(r"(\d{1,3}(?:\.\d{1,3}){2}\.(\d{1,3}))(?:(?:-|\s+to\s+)(\d{1,3}(?![\d\.]))|(?:-|\s*to\s+)(\d{1,3}(?:\.\d{1,3}){3})|\s+(25\d(?:\.\d{1,3}){3})|\s*\/(\d{1,3}))?")
test_str = ("ip: \"47.1.2.3\"\n"
"range: \"47.1.2.3-4\"\n"
"ip range: \"47.1.2.3-47.1.2.4\"\n"
"ip to range: \"47.1.2.3 to 4\"\n"
"ip to ip range: \"47.1.2.3 to 47.1.2.4\"\n"
"ip CIDR: \"47.1.2.4/32\"\n"
"ip Mask: \"47.1.2.4 255.255.255.255\"\n\n"
"what you want:\"47.1.2.3 to 4, 47.1.2.7, 47.1.3.9-47.1.3.19\"")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")