import Foundation
let pattern = #"(\d{1,3}(?:\.\d{1,3}){2}\.(\d{1,3}))(?:(?:-|\s+to\s+)(\d{1,3}(?![\d\.]))|(?:-|\s*to\s+)(\d{1,3}(?:\.\d{1,3}){3})|\s+(25\d(?:\.\d{1,3}){3})|\s*\/(\d{1,3}))?"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
ip: "47.1.2.3"
range: "47.1.2.3-4"
ip range: "47.1.2.3-47.1.2.4"
ip to range: "47.1.2.3 to 4"
ip to ip range: "47.1.2.3 to 47.1.2.4"
ip CIDR: "47.1.2.4/32"
ip Mask: "47.1.2.4 255.255.255.255"
what you want:"47.1.2.3 to 4, 47.1.2.7, 47.1.3.9-47.1.3.19"
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)