using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"""[^""]*""(*SKIP)(*F)|\s+";
string input = @" abc def "" gh i "" jkl "" m n o p "" qrst ""abc";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}