$re = '/"[^"]*"(*SKIP)(*F)|\s+/';
$str = ' abc def " gh i " jkl " m n o p " qrst "abc';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);