re = /"[^"]*"(*SKIP)(*F)|\s+/
str = ' abc def " gh i " jkl " m n o p " qrst "abc'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end