$re = '/^[^_]+_/m';
$str = 'name_001.png
na-m-e_001_tr.png';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;