import re
regex = re.compile(r"^[^_]+_", flags=re.MULTILINE)
test_str = ("name_001.png\n"
"na-m-e_001_tr.png")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)