using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<TD>(.*)<\/TD>";
string input = @"<TD>Cute Kittens</TD><TD>Funny Cats</TD>
--Try changing the .* to .*?";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}