package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`<TD>(.*)<\/TD>`)
var str = `<TD>Cute Kittens</TD><TD>Funny Cats</TD>
--Try changing the .* to .*?`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}