re = /<TD>(.*)<\/TD>/
str = '<TD>Cute Kittens</TD><TD>Funny Cats</TD>
--Try changing the .* to .*?'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end