$re = '/<TD>(.*)<\/TD>/';
$str = '<TD>Cute Kittens</TD><TD>Funny Cats</TD>
--Try changing the .* to .*?';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);