using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"msgid\s*(""(?:[^\\""]*\\.)*[^\\""]*"")";
string input = @"""Testing if \""quotes\"" are working."" from msgid ""Testing if \""quotes\"" are working.""";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}