re = /msgid\s*("(?:[^\\"]*\\.)*[^\\"]*")/
str = '"Testing if \\"quotes\\" are working." from msgid "Testing if \\"quotes\\" are working."'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end