$re = '/msgid\s*("(?:[^\\\\"]*\\\\.)*[^\\\\"]*")/';
$str = '"Testing if \\"quotes\\" are working." from msgid "Testing if \\"quotes\\" are working."';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);