use strict;
my $str = '#QST_COUPLE="Me contacter vous pour un problème de couple ?"#
[IF #COUPLE#]
[IF #!PRENOM_PARTENAIRE#]
Quel est le prénom de votre partenaire ?
#GET_PRENOM_PARTENAIRE#
Bien, nous allons pouvoir commencer votre tirage tarot maintenant !
[ELSE]
oooo
[/IF]
[/IF]
[IF #!CATEGORIE#]
[/IF]';
my $regex = qr/\[IF\s#(!)?([^\#]+)\#\](.*)(?:\[ELSE](.*))?\[\/IF]/sp;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}