// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?s)\[IF\s#(!)?([^\#]+)\#\](.*)(?:\[ELSE](.*))?\[\/IF]").unwrap();
let string = "#QST_COUPLE=\"Me contacter vous pour un problème de couple ?\"#
[IF #COUPLE#]
[IF #!PRENOM_PARTENAIRE#]
Quel est le prénom de votre partenaire ?
#GET_PRENOM_PARTENAIRE#
Bien, nous allons pouvoir commencer votre tirage tarot maintenant !
[ELSE]
oooo
[/IF]
[/IF]
[IF #!CATEGORIE#]
[/IF]";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}