import Foundation
let pattern = ##"\[IF\s#(!)?([^\#]+)\#\](.*)(?:\[ELSE](.*))?\[\/IF]"##
let regex = try! NSRegularExpression(pattern: pattern, options: .dotMatchesLineSeparators)
let testString = ##"""
#QST_COUPLE="Me contacter vous pour un problème de couple ?"#
[IF #COUPLE#]
[IF #!PRENOM_PARTENAIRE#]
Quel est le prénom de votre partenaire ?
#GET_PRENOM_PARTENAIRE#
Bien, nous allons pouvoir commencer votre tirage tarot maintenant !
[ELSE]
oooo
[/IF]
[/IF]
[IF #!CATEGORIE#]
[/IF]
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}