using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<a.*?<\/a>(*SKIP)(*F)|""([^""]*)""";
string substitution = @"»\1«";
string input = @"<p>This is a ""wonderful long text"". At least it should be. Here we have a <a href=""http://wwww.site-to-nowhere.com"" target=""_blank"">link</a>.</p>";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution, 1);
}
}