$re = '/<a.*?<\/a>(*SKIP)(*F)|"([^"]*)"/';
$str = '<p>This is a "wonderful long text". At least it should be. Here we have a <a href="http://wwww.site-to-nowhere.com" target="_blank">link</a>.</p>';
$subst = "»\1«";
$result = preg_replace($re, $subst, $str, 1);
echo "The result of the substitution is ".$result;