const regex = /<a.*?<\/a>(*SKIP)(*F)|"([^"]*)"/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<a.*?<\\\/a>(*SKIP)(*F)|"([^"]*)"', '')
const str = `<p>This is a "wonderful long text". At least it should be. Here we have a <a href="http://wwww.site-to-nowhere.com" target="_blank">link</a>.</p>`;
const subst = `»\1«`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);