#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "^require (['"])([.\w \/]+)\1"
Local $sString = "require "testing this out"" & @CRLF & _
"require "de/test/as.pen"" & @CRLF & _
"" & @CRLF & _
"....." & @CRLF & _
"" & @CRLF & _
"print "I require coffee in the morning" //problem"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")