$re = '/^require ([\'"])([.\w \/]+)\1/';
$str = 'require "testing this out"
require "de/test/as.pen"
.....
print "I require coffee in the morning" //problem';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);