using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^require (['""])([.\w \/]+)\1";
string input = @"require ""testing this out""
require ""de/test/as.pen""
.....
print ""I require coffee in the morning"" //problem";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}