re = /^require (['"])([.\w \/]+)\1/
str = 'require "testing this out"
require "de/test/as.pen"
.....
print "I require coffee in the morning" //problem'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end