using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @":[^:]+\K:.+:";
string input = @"source:connector:name/dir/dir/dir/container.zip:1000.msg:attachment.zip:folder/filename.zip";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}