const regex = /:[^:]+\K:.+:/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp(':[^:]+\\K:.+:', '')
const str = `source:connector:name/dir/dir/dir/container.zip:1000.msg:attachment.zip:folder/filename.zip`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}