re = /:[^:]+\K:.+:/
str = 'source:connector:name/dir/dir/dir/container.zip:1000.msg:attachment.zip:folder/filename.zip'
# Print the match result
str.match(re) do |match|
puts match.to_s
end