$re = '/:[^:]+\K:.+:/';
$str = 'source:connector:name/dir/dir/dir/container.zip:1000.msg:attachment.zip:folder/filename.zip';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);