import re
regex = re.compile(r"^\s*\d{1,2}(\s*[,\s]\s*\d{1,2})*\s*$", flags=re.MULTILINE)
test_str = ("11111111\n"
" 1\n"
" 1 2 3 3 4 5 7 17\n"
" 1, 2,3,11,74\n"
"1,11,14, 15\n"
"1,11,14,, 15\n"
"111, 101\n"
"1 2 3 a\n"
"1, 25, 5.0 \n"
"1,, 7, 80\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")