re = /^\s*\d{1,2}(\s*[,\s]\s*\d{1,2})*\s*$/m
str = '11111111
1
1 2 3 3 4 5 7 17
1, 2,3,11,74
1,11,14, 15
1,11,14,, 15
111, 101
1 2 3 a
1, 25, 5.0
1,, 7, 80
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end