#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^\d+:\d+:[^-]+-->.*\R+\K.+(?:\R.+)*(?=\s*(?:^\d+$|\z))"
Local $sString = "1" & @CRLF & _
"00:00:58,178 --> 00:00:59,327" & @CRLF & _
"Some text!" & @CRLF & _
"" & @CRLF & _
"2" & @CRLF & _
"00:00:59,329 --> 00:01:01,819" & @CRLF & _
"<i>Some text</i>" & @CRLF & _
"Some other<i>Some text</i>" & @CRLF & _
"Some other<i>Some text</i>" & @CRLF & _
"Some other<i>Some text</i>" & @CRLF & _
"Some other<i>Some text</i>" & @CRLF & _
"Some other<i>Some text</i>" & @CRLF & _
"Some other<i>Some text</i>" & @CRLF & _
"Some other<i>Some text</i>" & @CRLF & _
"Some other<i>Some text</i>" & @CRLF & _
"Some other" & @CRLF & _
"" & @CRLF & _
"3" & @CRLF & _
"00:01:40,512 --> 00:01:41,629" & @CRLF & _
"2350 some text." & @CRLF & _
"" & @CRLF & _
"4" & @CRLF & _
"00:01:41,631 --> 00:01:43,771" & @CRLF & _
"Some text." & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")