# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^\d+:\d+:[^-]+-->.*\R+\K.+(?:\R.+)*(?=\s*(?:^\d+$|\z))"
test_str = ("1\n"
"00:00:58,178 --> 00:00:59,327\n"
"Some text!\n\n"
"2\n"
"00:00:59,329 --> 00:01:01,819\n"
"<i>Some text</i>\n"
"Some other<i>Some text</i>\n"
"Some other<i>Some text</i>\n"
"Some other<i>Some text</i>\n"
"Some other<i>Some text</i>\n"
"Some other<i>Some text</i>\n"
"Some other<i>Some text</i>\n"
"Some other<i>Some text</i>\n"
"Some other<i>Some text</i>\n"
"Some other\n\n"
"3\n"
"00:01:40,512 --> 00:01:41,629\n"
"2350 some text.\n\n"
"4\n"
"00:01:41,631 --> 00:01:43,771\n"
"Some text.\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.