$re = '/^\d+:\d+:[^-]+-->.*\R+\K.+(?:\R.+)*(?=\s*(?:^\d+$|\z))/m';
$str = '1
00:00:58,178 --> 00:00:59,327
Some text!
2
00:00:59,329 --> 00:01:01,819
<i>Some text</i>
Some other<i>Some text</i>
Some other<i>Some text</i>
Some other<i>Some text</i>
Some other<i>Some text</i>
Some other<i>Some text</i>
Some other<i>Some text</i>
Some other<i>Some text</i>
Some other<i>Some text</i>
Some other
3
00:01:40,512 --> 00:01:41,629
2350 some text.
4
00:01:41,631 --> 00:01:43,771
Some text.
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);