const regex = /^\d+:\d+:[^-]+-->.*\R+\K.+(?:\R.+)*(?=\s*(?:^\d+$|\z))/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\d+:\\d+:[^-]+-->.*\\R+\\K.+(?:\\R.+)*(?=\\s*(?:^\\d+$|\\z))', 'gm')
const str = `1
00:00:58,178 --> 00:00:59,327
Some text!
2
00:00:59,329 --> 00:01:01,819
<i>Some text</i>
Some other<i>Some text</i>
Some other<i>Some text</i>
Some other<i>Some text</i>
Some other<i>Some text</i>
Some other<i>Some text</i>
Some other<i>Some text</i>
Some other<i>Some text</i>
Some other<i>Some text</i>
Some other
3
00:01:40,512 --> 00:01:41,629
2350 some text.
4
00:01:41,631 --> 00:01:43,771
Some text.
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}