#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?i)(^|[^<>])\b((?:https?|ftp):\/\/[^<>\s]+\b)"
Local $sString = "http://www.google.com here and https://google.com ftp://google.com " & @CRLF & _
"<http://www.google.com> here and <https://google.com> <ftp://google.com>"
Local $sSubst = "$1<a href="$2">$2</a>"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)