re = /(^|[^<>])\b((?:https?|ftp):\/\/[^<>\s]+\b)/i
str = 'http://www.google.com here and https://google.com ftp://google.com
<http://www.google.com> here and <https://google.com> <ftp://google.com>'
subst = '$1<a href="$2">$2</a>'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result